Debenhams

Zyxel

Gs1350-26hp Network Switch Managed L2 Gigabit Ethernet

£487.02
Colour: Grey
Premier Logo
Enjoy unlimited delivery for an entire year for £7.49
Debenhams Shipping Insurance Logo
Peace of mind, guaranteed
Free & simple resale - recover value and give your items a second life
+14-day return extension
£5/day late delivery compensation
Full order coverage (lost, stolen, damaged) with instant payout on eligible claims
Learn More

“Refund was approved and back in my account the same day.” - Deliver+ customer

Delivery Methods
Sold & Delivered by SOLIT.ME
Eligible for return within 21 days. Plus 14-day extension when you purchase Debenhams Deliver+Exclusions apply. Please see our returns policy
paypal Iconclearpay Icondebenhams Icondebenhams Icon
18+, T&C apply. Credit subject to status.
See more
At a Glance
Auto-detects failed IP cameras
Extended range up to 250m
375W PoE power budget
24 Gigabit PoE ports
One-touch restore button
Description

Crafted for CCTV surveillance applications, this smart managed switch features specialised PoE software designed to detect and recover failed IP cameras and powered devices automatically with customisable parameters. It delivers continuous power to keep cameras operational even during switch maintenance, significantly reducing reboot time. The switch fulfils the need to deploy IP cameras using existing Cat 5e cable to distant locations, achieving deployments up to 250 metres in extended-range mode. With a large power budget of up to 375 watts, it accommodates multiple IP cameras. The intuitive LED indicators on the front panel allow inspection of real-time PoE status, and the one-touch restore button enables effortless recovery from misconfigurations. The robust design includes stabilised power filters to reduce electrical noise and surge protection. Selected power supply includes 2X surge and ESD protection with isolated circuit design and patented Ethernet protection featuring 4X surge protection and 2X ESD resistance.

SKU: M4718937604463
Product Details & Care

Switch type: Managed; Switch layer: L2; Web-based management: Yes; Configuring Location Settings (CLI): Yes; System event log: Yes; MIB support: RFC 1066, RFC 1213, 1157, RFC 1493, RFC 1643, RFC 1757, RFC 2011, 2012, 2013, RFC 2233, RFC 2358, RFC 2674, RFC 2819, 2925, RFC 3621, RFC 4293, RFC 4292, RFC 4022, RFC 4113; Basic switching RJ-45 Ethernet ports quantity: 24; Basic switching RJ-45 Ethernet ports type: Gigabit Ethernet (10/100/1000); Combo SFP ports quantity: 2; Networking standards: IEEE 802.1D, IEEE 802.1ab, IEEE 802.1p, IEEE 802.1w, IEEE 802.3, IEEE 802.3ad, IEEE 802.3af, IEEE 802.3at, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z; 10G support: No; Copper ethernet cabling technology: 10BASE-T, 100BASE-TX, 1000BASE-T; Port mirroring: Yes; Flow control support: Yes; Broadcast storm control: Yes; Rate limiting: Yes; Spanning tree protocol: Yes; VLAN support: Yes; Virtual LAN features: MAC address-based VLAN, Port-based VLAN; Number of VLANs: 256; Fiber ethernet cabling technology: 1000BASE-X; Switching capacity: 52 Gbit/s; Forwarding rate: 38.7 Mpps; MAC address table: 8000 entries; Packet buffer memory: 0.525 MB; DHCP features: DHCP client, DHCP relay, DHCP snooping; IGMP snooping: Yes; IGMP proxy: Yes; Security algorithms: SNMP, SNMPv3, SSH, SSL/TLS; Loop protection: Yes; Queue scheduling algorithms: SPQ, WFQ, Weighted Round Robin (WRR); Multicast support: Yes; Rack mounting: Yes; Product colour: Grey; LED indicators: Yes; Electromagnetic compatibility: CE, FCC, C-Tick, A; BSMI CNS13438; Noise level: 40.1 dB; Firmware upgradeable: Yes; Mean time between failures (MTBF): 888495 h; AC input voltage: 100 - 240 V; AC input frequency: 50 - 60 Hz; Power consumption (max): 448.9 W; Power over Ethernet (PoE): Yes; Power over Ethernet (PoE) ports quantity: 24; Total Power over Ethernet (PoE) budget: 375 W; Operating temperature (T-T): -20 - 50 °C; Storage temperature (T-T): -40 - 70 °C; Operating relative humidity (H-H): 5 - 95%; Storage relative humidity (H-H): 5 - 95%; Heat dissipation: 1530.75 BTU/h; Width: 441 mm; Depth: 270 mm; Height: 44 mm; Weight: 3.58 kg; Cables included: AC; Rack mount kit: Yes; Harmonized System (HS) code: 85176990

Delivery

Free Delivery For A Year With Unlimited Delivery

Super Saver Delivery

£2.99

99p on orders over £30

Standard Delivery

£3.99

Express Delivery

£5.99

Next Day Delivery

£6.99

Order before Midnight

24/7 InPost Locker | Shop Collect

£2.49

Evri ParcelShop

£3.99

Evri ParcelShop | Next Day Delivery

£5.99

Premium DPD Next Day Delivery

£6.99

Order before 9pm Sunday - Friday and before 8pm Saturday

Bulky Item Delivery

£4.99

Northern Ireland Super Saver Delivery

£2.99

Northern Ireland Standard Delivery

£4.99

Northern Ireland Express Delivery

£5.99

Order before 7pm Sunday - Thursday (Delivery Monday - Saturday)

Unlimited Delivery

£7.49

Free Delivery For A Year. Was £14.99, Now £7.49 For A Limited Time Only.

Find Out More

Please note, some delivery methods are not available for products delivered by our brand partners & they may have longer delivery times.

Find out more

Returns

Something not quite right? You have 21 days from the day you receive it, to send something back. When you purchase Debenhams Deliver+, you will have an extra 14 days on top of our standard 21-day window to initate a return.

Please note, we cannot offer refunds on fashion face masks, cosmetics, pierced jewellery, adult toys, and swimwear or lingerie if the hygiene seal is not in place or has been broken.

Items of footwear and/or clothing must be unworn and unwashed with the original labels attached. Also, footwear must be tried on indoors. Items of homeware including bedlinen, mattresses, and toppers, and pillows must be unused and in their original unopened packaging. This does not affect your statutory rights.

Click here to view our full Returns Policy.

We Think You'll Like

Sponsored Products