Debenhams

Zyxel

Gs1900-24hp Managed Gigabit Ethernet Switch

£353.77
Colour: Black
Size: One Size
Only 3 left in stock
Premier Logo
Enjoy unlimited delivery for an entire year for £10
Debenhams Shipping Insurance Logo
Peace of mind, guaranteed
Free & simple resale - recover value and give your items a second life
+14-day return extension
£5/day late delivery compensation
Full order coverage (lost, stolen, damaged) with instant payout on eligible claims
Learn More

“Refund was approved and back in my account the same day.” - Deliver+ customer

Delivery Methods
Sold & Delivered by SOLIT.ME
Eligible for return within 21 days. Plus 14-day extension when you purchase Debenhams Deliver+Exclusions apply. Please see our returns policy
paypal Iconclearpay Icondebenhams Icondebenhams Icon
18+, T&C apply. Credit subject to status.
See more
At a Glance
24 PoE+ Gigabit Ports
Easy Web-Based Management
Fanless Energy-Efficient Design
Advanced Security Features
Flexible Mounting Options
Description

Simple, Fast and Smart Managed Switch for Small Business Connectivity. The GS1900 Series Smart Managed Switch with Gigabit speed and essential managing functions brings your business network flexibility and connectivity. The Series features power-saving functions, fanless design and full IPv6 support. PoE models comply with IEEE 802.3at Power over Ethernet Plus standard. The complete GS1900 Series offers compact desktop and rackmount sizes with GbE connectivity. All models support multiple deployment methods including wall-mounted, under table, desktop-mounted and rackmount options. Select models are equipped with 2 extra SFP slots for long-distance deployments. The GS1900 Series comes with a friendly built-in Web-based browser for simple configuration and management. The intuitive wizard helps with quick setup in minutes. VLAN, Guest VLAN and QoS settings are guided through common steps for easy deployment. Advanced management features make the network stable and secure including loop protection, dual images for backup firmware, and storm control. SSL encryption protects management frames when accessed. The built-in IEEE 802.3az Energy Efficient Ethernet and green features reduce energy consumption through intelligent methods.

SKU: M4718937609505
Product Details & Care

Switch type: Managed; Quality of Service (QoS) support: Yes; MIB support: RFC 1213 MIB II, RFC 2819, RFC 1215, RFC 1493; Basic switching RJ-45 Ethernet ports quantity: 24; Basic switching RJ-45 Ethernet ports type: Gigabit Ethernet (10/100/1000); Gigabit Ethernet (copper) ports quantity: 24; SFP module slots quantity: 2; Networking standards: IEEE 802.1p, IEEE 802.3, IEEE 802.3ab, IEEE 802.3af, IEEE 802.3at, IEEE 802.3az, IEEE 802.3u, IEEE 802.3x; Copper ethernet cabling technology: 10BASE-T, 100BASE-T, 1000BASE-T; Flow control support: Yes; Broadcast storm control: Yes; Rate limiting: Yes; Security algorithms: 802.1x RADIUS; MAC address filtering: Yes; SSH/SSL support: Yes; Management protocols: SNMP v1,v2,v3, RMON (1,2,3,9); Form factor: 1U; Product colour: Black; Power supply included: Yes; Certification: CE, FCC, C-Tick, Class A (GS1900-8HP/24/24HP/48/48HP) CE, FCC, C-Tick, Class B (GS1900-8/16/24E) BSMI CNS13438; Harmonized System (HS) code: 85176990

Returns

Something not quite right? You have 21 days from the day you receive it, to send something back. When you purchase Debenhams Deliver+, you will have an extra 14 days on top of our standard 21-day window to initate a return.

Please note, we cannot offer refunds on fashion face masks, cosmetics, pierced jewellery, adult toys, and swimwear or lingerie if the hygiene seal is not in place or has been broken.

Items of footwear and/or clothing must be unworn and unwashed with the original labels attached. Also, footwear must be tried on indoors. Items of homeware including bedlinen, mattresses, and toppers, and pillows must be unused and in their original unopened packaging. This does not affect your statutory rights.

Click here to view our full Returns Policy.

We Think You'll Like

Sponsored Products