Debenhams

Zyxel

Gs1920-8hpv2 Managed Gigabit Ethernet Switch

£266.52
Colour: Black
Size: One Size
Only 1 left in stock
Premier Logo
Enjoy unlimited delivery for an entire year for £10
Debenhams Shipping Insurance Logo
Peace of mind, guaranteed
Shop with Deliver+ for your chance to win £50k or a Range Rover Evoque
Price Promise - Find it cheaper elsewhere before 30th November & we'll refund the difference
+14-day return extension
£5/day late delivery compensation
Learn More

“Refund was approved and back in my account the same day.” - Deliver+ customer

Delivery Methods
Sold & Delivered by SOLIT.ME
Eligible for return within 21 days. Plus 14-day extension when you purchase Debenhams Deliver+Exclusions apply. Please see our returns policy
paypal Iconclearpay Icondebenhams Icondebenhams Icon
18+, T&C apply. Credit subject to status.
See more
At a Glance
375W Total PoE Power
8 Gigabit PoE Ports
Smart Power Management Technology
Silent Temperature-Controlled Fan
Intuitive Web-Based Management
Description

Advanced smart managed switching that minimises wasteful overpowering of devices and helps your business save money and time whilst powering more devices. Perfect for small to medium-sized businesses, this smart managed switch is rich in L2 features and provides 375 watts over Ethernet for reliable and future-proof networking. The intuitive web-based interface allows access to L2 features such as LACP, advanced QoS, VLAN, ACL and multicast IGMP snooping without learning complex command-line interfaces. Consumption mode allows delivery of only the actual power required for greater efficiency and better return on investment for your business. The in-built smart fan is designed to automatically adjust speed based on device temperature, ensuring silent and reliable switch operation ideal for both desktop and rack-mounted office environments. The management platform provides easy network maintenance with a free tool that allows you to install, configure and discover switches, WLAN and gateways in your network with one-click convenience. This futureproofs your network for growth with Gigabit copper ports for enhanced connectivity and performance across your business infrastructure.

SKU: M4718937602230
Product Details & Care

Switch type: Managed; Quality of Service (QoS) support: Yes; ARP inspection: Yes; System event log: Yes; MIB support: RFC 1066, RFC 1213, RFC 1157, RFC 1493, RFC 1643, RFC 1757, RFC 2011.2012,2013, RFC 2233, RFC 2358, RFC 2674, RFC 2819,2925, RFC 3621, RFC 4022, RFC 4113, RFC 4292, RFC 4293; Basic switching RJ-45 Ethernet ports quantity: 8; Basic switching RJ-45 Ethernet ports type: Gigabit Ethernet (10/100/1000); Combo SFP ports quantity: 2; Fiber optic connector: SFP; Networking standards: IEEE 802.1D, IEEE 802.1Q, IEEE 802.1ab, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3af, IEEE 802.3at, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z; 10G support: No; Copper ethernet cabling technology: 100BASE-TX, 1000BASE-T; Flow control support: Yes; Rate limiting: Yes; Spanning tree protocol: Yes; VLAN support: Yes; Virtual LAN features: Private VLAN, Voice VLAN, Protocol-based VLAN, MAC address-based VLAN, Port-based VLAN, IP subnet–based VLAN; Fiber ethernet cabling technology: 1000BASE-X; Switching capacity: 20 Gbit/s; Forwarding rate: 15 Mpps; MAC address table: 16000 entries; Packet buffer memory: 1.5 MB; DHCP features: DHCP snooping, DHCP relay, DHCPv6 relay, DHCP client; Access Control List (ACL): Yes; IGMP snooping: Yes; Security algorithms: 802.1x RADIUS, SNMP, SNMPv3; MAC address filtering: Yes; IP-MAC-Port binding: Yes; Authentication: Guest VLAN, Port-based authentication; Password protection: Yes; Authentication type: IEEE 802.1x, RADIUS; CPU defense: Yes; Queue scheduling algorithms: SPQ, WFQ, Weighted Round Robin (WRR); Multicast support: Yes; Rack mounting: No; Product colour: Black; LED indicators: Yes; Wall mountable: Yes; Safety: LVD, BSMI; Electromagnetic compatibility: FCC 15 A, CE A, BSMI EMC; Internal memory: 256 MB; Flash memory: 32 MB; Noise level: 0 dB; Mean time between failures (MTBF): 513985 h; AC input voltage: 100 - 240 V; AC input frequency: 50 - 60 Hz; Power consumption (max): 161.8 W; Power over Ethernet (PoE): Yes; Power over Ethernet (PoE) ports quantity: 8; Total Power over Ethernet (PoE) budget: 130 W; Operating temperature (T-T): 0 - 50 °C; Storage temperature (T-T): -40 - 70 °C; Operating relative humidity (H-H): 10 - 95%; Storage relative humidity (H-H): 10 - 95%; Heat dissipation: 551.74 BTU/h; Width: 267 mm; Depth: 162 mm; Height: 44 mm; Weight: 1.9 kg; Cables included: AC; Package width: 375 mm; Package depth: 235 mm; Package height: 61 mm; Package weight: 2.73 kg; Certification: RoHS; Harmonized System (HS) code: 85176990

Returns

Extended returns Orders placed after 29th October 2026 can be returned until 5th January 2027

Something not quite right? You have 21 days from the day you receive it, to send something back. When you purchase Debenhams Deliver+, you will have an extra 14 days on top of our standard 21-day window to initate a return.

Please note, we cannot offer refunds on fashion face masks, cosmetics, pierced jewellery, adult toys, and swimwear or lingerie if the hygiene seal is not in place or has been broken.

Items of footwear and/or clothing must be unworn and unwashed with the original labels attached. Also, footwear must be tried on indoors. Items of homeware including bedlinen, mattresses, and toppers, and pillows must be unused and in their original unopened packaging. This does not affect your statutory rights.

Click here to view our full Returns Policy.

We Think You'll Like

Sponsored Products